错误:在DefaultExternalModuleDependency {group ='com.android.support',name ='appcompat-v7',version ='上找不到参数[com.android.support:support-v4:25.0.3]的方法compile() 25.0.3”,配置=“默认”}。 请从Android SDK Manager安装Android支持存储库。开启Android SDK Manager 我不知道这是怎么发生的,我已经多次检查了文件,但是,我找不…

2020年12月2日 0条评论 67点热度 阅读全文

因此,我有一个Android基础项目,希望将其拆分为各种样式。分配单独的xml很容易,类也很容易。但是,当有从基类到 flavor 类的调用时,就会出现问题。举例来说,我有: package app.myapp.service import app.flavor1.ClassB import app.flavor2.ClassB import app.flavor3.ClassB import app.flavor4.ClassB public class Class A { Class B bar = new C…

2020年11月30日 0条评论 37点热度 阅读全文

我通过添加如下所示的“存储库”和“依赖项”行修改了gradle.build模块文件。构建成功返回,但是当我检查/ libs时,jar的1.2.0版本不存在,并且在整个Java代码中都出现“无法解析符号”错误。该构建与/ libs中的achartengine-1.1.0.jar配合良好,因此gradle如何访问(复制或临时)构建的achartengine-1.2.0.jar似乎是一个问题(我是新的到Gradle)。 apply plugin: 'com.android.application' android { c…

2020年11月29日 0条评论 27点热度 阅读全文

我的一个Android项目目前面临一种情况。 情况是: 项目使用库A和B(新版本)。库A也取决于库B(旧版本)。 A和B都是独立维护的,它们的发布无法同步。 库B的旧版本和新版本不兼容,因为某些接口(interface)定义在新版本中已更改。我认为这会在构建项目时带来一些问题。 在我的android项目中同时维护A和B的最佳方法是什么? 解决方案如下: 正如评论中已经指出的那样,没有针对您的问题的现成解决方案,您最好的选择可能是使您的项目使用库A使用的相同版本的库B。 仅当您真正依赖仅在新版本B中可用的功能或修补程…

2020年11月24日 0条评论 45点热度 阅读全文

更新到Android Studio 3.1之后,我遇到了这个错误。 注意:我使用的是Java而不是Kotlin Could not find org.jetbrains.kotlin:kotlin-stdlib-jre8:1.2.0. Searched in the following locations: https://maven.fabric.io/public/org/jetbrains/kotlin/kotlin-stdlib-jre8/1.2.0/kotlin-stdlib-jre8-1.2.0.pom…

2020年11月24日 0条评论 48点热度 阅读全文

我正在尝试使用来自Facebook的this example从我的Android项目共享位图,但是 当我在我的项目中实现示例时-没有任何反应,没有警告,没有错误。这是我的代码: shareButton.setOnClickListener(new OnClickListener() { @Override public void onClick(View v) { Bitmap image = BitmapFactory.decodeResource(getResources(), R.drawable.ic_la…

2020年11月22日 0条评论 31点热度 阅读全文

Gradle坚持下载一些依赖项两个这样的依赖是 org.parceler:parceler-api:1.0.4 io.fabric.tools:gradle:1.+ 如果我在gradle文件中评论它们-构建将继续进行 找不到问题,除非我手动取消,否则它仅显示正在下载 parceler-1.0.4.jar,并永远显示相同的消息。 版本 Android Studio:2.0 Beta 5 Gradle :2.11(也尝试2.10) 解决方案如下: 您是否尝试在浏览器中(或通过wget)访问依赖项URL?您可以手动下载依…

2020年11月21日 0条评论 28点热度 阅读全文

任何人都可以通过以下错误帮助我。当我清理项目时,它没有显示任何错误,但是每次我尝试运行时,都会收到此消息。 错误:任务':app:dexDebug'的执行失败。 com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Program Files\Java\jdk1.8.0_45\bin\java.exe'' finished with non-ze…

2020年11月21日 0条评论 49点热度 阅读全文

如https://developer.android.com/studio/build/gradle-plugin-3-0-0-migration.html#new_configurations中所述,我们现在有了api和implementation。 在Android模块(即apply plugin: 'com.android.application')中,我们确实拥有两者。 但是在普通的Java模块即apply plugin: 'java'(由我的Android应用模块使用)中,我只能找到implementat…

2020年11月20日 0条评论 49点热度 阅读全文

我正在尝试使用来自Facebook的this example从我的Android项目共享位图,但是 当我在我的项目中实现示例时-没有任何反应,没有警告,没有错误。这是我的代码: shareButton.setOnClickListener(new OnClickListener() { @Override public void onClick(View v) { Bitmap image = BitmapFactory.decodeResource(getResources(), R.drawable.ic_la…

2020年11月19日 0条评论 44点热度 阅读全文