在带有brew的Mac上安装Zeppelin:需要Java 1.7

2019年7月15日 11点热度 0条评论

我正在尝试在macOS High Sierra上安装Apache Zeppelin。遵循文档(https://www.datageekinme.com/setup/setting-up-my-mac-zeppelin/):

hlepouse@Hadriens-MacBook-Pro:~$ brew install apache-zeppelin
apache-zeppelin: Java 1.7 is required to install this formula.
Install AdoptOpenJDK 8 with Homebrew Cask:
  brew cask install homebrew/cask-versions/adoptopenjdk8
Error: An unsatisfied requirement failed this build.

但是我已经安装了AdoptOpenJDK 8:

hlepouse@Hadriens-MacBook-Pro:~$ brew cask install homebrew/cask-versions/adoptopenjdk8
Updating Homebrew...
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/cask).
No changes to formulae.

Warning: Cask 'adoptopenjdk8' is already installed.
hlepouse@Hadriens-MacBook-Pro:~$ java -version
openjdk version "1.8.0_242"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_242-b08)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.242-b08, mixed mode)
hlepouse@Hadriens-MacBook-Pro:~$ /usr/libexec/java_home -V
Matching Java Virtual Machines (3):
    14, x86_64: "OpenJDK 14"    /Library/Java/JavaVirtualMachines/openjdk-14.jdk/Contents/Home
    1.8.0_242, x86_64:  "AdoptOpenJDK 8"    /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home
    1.8.0_171, x86_64:  "Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_171.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/openjdk-14.jdk/Contents/Home
hlepouse@Hadriens-MacBook-Pro:~$ echo $JAVA_HOME
/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home

我不明白我在做什么错。

当建议安装AdoptOpenJDK 8时,为什么需要Java 1.7?我也找不到安装Java 1.7的方法。

解决方案如下:

由于Java 7已经停产,我们在this PR中将其删除。

我只是在自己的水龙头中上传了一个,请告诉我是否适合您。

brew install chenrui333/tap/apache-zeppelin