使用Android开发工具23版更新Eclipse

2019年4月23日 36点热度 0条评论

我使用新的SDK工具(修订版23)更新了Eclipse,但是现在当Eclipse启动时,我收到以下错误消息:

This Android SDK requires Android Developer Toolkit version 23.0.0 or above. Current version is 22.6.3.v201404151837-1123206. Please update ADT to the latest version.

找不到
“检查更新” 更新。如果尝试使用
“安装新软件” ,则可以看到版本23,但由于以下错误而无法升级:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

从网站上下载了最新的ADT之后,似乎还有另一个问题。

使用SDK工具版本。 23未安装proguard,缺少SDK文件夹
dir/tools/proguard,并且缺少其他工具。这个版本包含几个错误。

解决方案如下:

Google已发布ADT v23.0.2。这解决了以前的ADT版本23的许多问题。

一步步:

  • 菜单帮助→安装新软件...
  • 对于“使用”,请选择Android源https://dl-ssl.google.com/android/eclipse
  • 勾选ADT v23.0进行安装,然后单击“下一步”。
  • Eclipse将显示“Install Remediation Page”,因为与先前版本存在冲突。 (如果没有,请参见下文。)选择“更新我的安装以使其与所安装的项目兼容”以卸载旧版本并安装新版本。之后,继续执行通常的步骤。
  • 注意:安装新版本的ADT时,未包括新版本的“Android Native Development Tools”软件包。相反,我先安装了其余的程序包,然后安装了“Android Native Development Tools”。由于某种原因,如果我尝试安装所有新软件包,包括“Android Native Development Tools”,则安装将失败。

    如果没有“修复页面”,则为
    the only way to remove the ADT plugin from Eclipse is to go to menu HelpAbout EclipseInstallation Details and uninstall from there。但是存在卸载Eclipse本身的风险。